题目传送门:http://poj.org/problem?id=1579
Function Run Fun
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 20560 | Accepted: 10325 |
Description
We all love recursion! Don’t we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) – w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) – w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
Source
题意概括:
要求写一个函数 w( a, b, c) 处理输入数据(多测试);
①如果 a < 0 || b < 0 || c < 0;直接返回w( a, b, c );
②如果 a > 20 || b > 20 || c > 20;返回w( 20, 20, 20 );
③如果 a < b && b < c ;返回 w(a, b, c-1) + w(a, b-1, c-1) – w(a, b-1, c);
④ 其他情况返回w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) – w(a-1, b-1, c-1) ;
解题思路:
记忆化搜索裸题。
AC code:
/// POJ 1579 记忆化搜索入门
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#define ll long long int
#define INF 0x3f3f3f3f
using namespace std; const int MAXN = ;
int d[MAXN][MAXN][MAXN]; int dfs(int a, int b, int c)
{
if(a <= || b <= || c <= ) return ;
if(a > || b > || c > ) return dfs(, , );
if(d[a][b][c]) return d[a][b][c];
if(a < b && b < c) d[a][b][c] = dfs(a, b, c-)+dfs(a, b-, c-) - dfs(a, b-, c);
else d[a][b][c] = dfs(a-, b, c)+dfs(a-, b-, c)+dfs(a-, b, c-)-dfs(a-,b-,c-);
return d[a][b][c];
}
int main()
{
int ans, A, B, C;
memset(d, , sizeof(d));
while(~scanf("%d%d%d", &A, &B, &C))
{
if(A == - && B == - && C == -) break;
ans = dfs(A, B, C);
printf("w(%d, %d, %d) = %d\n", A, B, C, ans);
}
return ;
}